#安装与更新 [TOC] ## 运行环境 #### 版本要求 HDPHP框架需要PHP版本7或更高版本才可以运行,并要求具有以下扩展。 ``` PHP >= 7.0.0 OpenSSL PHP Extension PDO PHP Extension Mbstring PHP Extension ``` #### 服务器环境 因为PHP软件是跨平台的,hdphp框架是PHP语言所开发的,所以是可以运行在 UNIX、LINUX、WINDOWS、苹果 Macintosh 等平台系统上的。 #### 开发工具 * windows 环境下推荐使用 [wamp](http://www.wampserver.com/en/) 或 [phpstudy](http://www.phpstudy.net/) 集成化环境进行学习使用 * mac 环境下建议使用 [mamp](https://www.mamp.info/en/) ## 安装方法 ####命令安装(推荐) 框架是组件化思想开发,使用composer管理每个组件包,所以使用composer安装是最方便的,也是建议使用的安装方式,通过以下命令可以快速安装HDPHP框架。 当然有些情况下可能出现安装时间过长或失败的情况,这是因为使用composer需要访问国外网站,而你所在的网络无法访问国外网站造成的,所以建议你购买一款VPN服务,其实做为一个程序员VPN应该是我们的标配。 ``` composer create-project houdunwang/hdphp blog --prefer-dist ``` #### 下载压缩包 如果没有VPN服务又想体验HDPHP框架,也可以通过官网进行下载,但显然这样有些不智能。 登录 [hdphp官网](http://www.hdphp.com) 下载hdphp3 框架